SharePoint Designer shows “There are no items to show in this view” message

I loaded SharePoint Designer this morning and when I clicked on the Lists and Libraries navigation item I saw just a blank screen with the message “There are no items to show in this view”. 

I knew that I recently made some changes to some List Definitions (I deleted a list definition from my solution) so my first assumption was that I broke something by doing so. 

SharePoint Designer uses the /_vti_bin/ListData.svc web service to pull content, so by breaking the list definition, the web service broke as well and could no longer return valid values.

To fix the issue, I went to “All FilesLists” in SharePoint Designer and then, one at a time, I clicked on a list and then the Preview in Browser button in the ribbon. If the list loaded, everything was fine, but eventually I found the list that failed. I deleted that list and then went back to the Lists and Libraries section and everything work normally!

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out /  Change )

Google+ photo

You are commenting using your Google+ account. Log Out /  Change )

Twitter picture

You are commenting using your Twitter account. Log Out /  Change )

Facebook photo

You are commenting using your Facebook account. Log Out /  Change )

Connecting to %s

This site uses Akismet to reduce spam. Learn how your comment data is processed.